Gentoo ja libexpat.so.0 probleem

seoses expat paketi uuendusega läksid paljud programmid gentoo all katki. Õpetuseks soovitatakse mitte kasutada linkimist kus libexpat.so.0 luuakse ise käsitsi softlingina libexpat.so.1 vms peale, vaid kompileerida probleemist puudutatud paketid ümber käsuga:


revdep-rebuild -X --library=libexpat.so.0

ent vähemalt minu masinas jooksid isegi sellise kompileerimise tulemusena kõik liiva, sest keset kompileerimist (gtk+ puhul näiteks) tuli veateade kus kurdeti libexpat.so.0 puudumise üle. Äkki aga hakkasid kõik asjad tööle ning ainuke seletus tundub olevat asi mida enne ei proovinud – nimelt gentoo foorumis soovitatakse gtk+ kompileerimise vea puhul käske:

emerge fontconfig
emerge pango
emerge gtk+

ja voila! peale kahe esimese paketi ümberkompileerimist läksid nii gkrellm2 kui firefox kohe käima.

Advertisements

Lisa kommentaar

Täida nõutavad väljad või kliki ikoonile, et sisse logida:

WordPress.com Logo

Sa kommenteerid kasutades oma WordPress.com kontot. Logi välja / Muuda )

Twitter picture

Sa kommenteerid kasutades oma Twitter kontot. Logi välja / Muuda )

Facebook photo

Sa kommenteerid kasutades oma Facebook kontot. Logi välja / Muuda )

Google+ photo

Sa kommenteerid kasutades oma Google+ kontot. Logi välja / Muuda )

Connecting to %s

%d bloggers like this: